jump to navigation

Redistribución estática en RIPSeptember 14, 2006



Cuando un sistema autónomo posee una sola puerta de entrada/salida se puede configurar una ruta estática o una ruta estática por default de manera que todos los paquetes que quieran llegar a múltiples redes externas lo hagan por medio de esa ruta preestablecida. Para que todos los router contenidos dentro del mismo sistema autónomo tengan conocimiento de la existencia de esa ruta es necesario redistribuirla dentro del protocolo. Esto se hace con el comando redistribute static.

 

En el siguiente ejemplo se ha configurado una ruta estática por default,  que sale a través de la interfaz Serial 0 del router. Esta interfaz se ha “pasivado” de manera que no transmita información de protocolo hacia el router conectado directamente con esa interfaz, utilizando el comando:                           
passive-interface serial0.

 

Router(config)#ip route 0.0.0.0 0.0.0.0 serial0                                              
Router(config)#router rip                        
Router(config-router)#network 192.168.1.0                                        
Router(config-router)#network 200.200.10.0                                          
Router(config-router)#redistribute static    
Router(config-router)#passive-interface serial 0

 

La siguiente captura del show ip route del router  muestra en la ultima línea como ha aprendido la ruta estática por medio de RIP ilustrado por R*, donde R es RIP y * ruta candidata por defecto.
Router_A#show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
       D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
       N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
       E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
       i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, * – candidate default
       U – per-user static route, o – ODR
  
Gateway of last resort is 172.25.1.1 to network 0.0.0.0

C    192.168.1.0/24 is directly connected, Ethernet0
C    200.200.1.0/24 is directly connected, Ethernet1
R    204.170.0.0/24 [120/5] via 172.25.2.1, 00:00:15, Serial0
R    172.16.0.0/16 [120/8] via 172.25.2.1, 00:00:20, Serial1
R*   0.0.0.0/0 [120/1] via 172.25.2.1, 00:00:02, Serial0.1

 

Comparte este contenido:
  • Print
  • Digg
  • del.icio.us
  • Facebook
  • Twitter

Si el material de este post te ha sido de utilidad colabora y difúndelo.











Aprenderedes.com fue creado con fines educativos, NO responderé consultas técnicas ni fuera del temario CCNA.»

1. amoxicillin - October 18, 2006

Avete blog piacevole qui! Grazie, è molto duro a mine lle tai informazioni in italiano, ma scrivete molto chiaro e posso capire tutto.

2. Rodrigo - April 24, 2008

MUY BUENO ESTE CURSO LA VERDAD ENSEÑA A COMPRENDER MEJOR EL CCNA…
GARCIAS.

3. Jocelyn - April 28, 2008

Es bueno, pero igual podria ver como se hace un redistribute con igrp

gracias

4. Carlos - July 3, 2008

Estimado.

Lo felicito verdaderamente por el aporte.
Que prolifere los seres humanos como Ud.

Una pregunta sobre un tópico que no tengo lo suficientemente claro:

Los comandos para realizar la redistribucion de rutas cuando se levanta sobre una topologia enrutamiento multiprotocolo.

ejemplo: EIGRP, RIPv2 y OSPF.

Como redistribuyo rutas de OSPF EIGRP en ambos sentidos?

O

RIPEIGRPOSPF.

y si hay rutas estáticas?.

le agradezco mucho me aclare los comados para levantar mi red mltienrutamiento.

GRACIAS

5. Ernesto Ariganello - July 3, 2008

Carlos, para redistribuir entre protocolos con metricas compuestas debes ademas redistribuir las metricas de cada protocolo.
por ejemplo
Router(config)#router eigrp 20
Router(config-router)#redistribute ospf 10
Router(config-router)#default-metric 10000 100 255 1 1500

un saludo

6. Stefano - July 8, 2008

¿Como redistribuyo Eigrp y rip?

7. Victor - August 2, 2008

Buenas, amigos espero me resuelvan esta duda.. tengo que armar una topologia multiprotocolo entre ospf y eigrp, ¿cómo hago para que los routers ospf me aprendan las rutas eigrp? muchas gracias

8. Ernesto Ariganello - August 3, 2008

Victor, debes redistribuir los protocolos.

S2

9. juan - September 10, 2008

que tal !,, tengo una duda , como puedo configurar una red EIGRP Y RIP de tal manera que EIGRP no se comunique con RIP .. como establecer esa ruta estatica ?

10. pamela Luna - September 15, 2008

hola, que tal, me parace magnifica la pagina ya que aprendo mucho de ella, tengo una consulta, quiero saber si la configuracion de puertos y protocolos asi como NAT,TELNET, VLANs etc etc es la misma en un router CISCO y en otro tipo de routers como DLink?
o es que para otras marcas de routers es diferente la programacion? espero que pueda contestarme y resolver esta duda que tengo, ya que muchas personas que conozco quieren aprender a configurar routers pero no saben cual ya que piensan que la configuracion para cada uno de ellos es diferente.

11. Ernesto Ariganello - September 15, 2008

Pamela, las configuraciones de los routers Cisco son propietarias, sin embargo como se basan en unix son aplicables con algunas diferencias en otros fabricantes. Es muy recomendable comenzar por Cisco, no solo desde para el estudiante sino tambiem luego en el trabajo diario.

Un saludo

12. Pamela Luna - September 15, 2008

Hola, ernesto, significa que si adquiero un router Dlink u otro que no sea cisco podre aplicar todos mis conocimientos adquiridos para configuracion de routers cisco, excepto algunas diferencias? perdon por la insistencia.

13. gaston - September 15, 2008

con respecto a lo que dijo pamela, tengo el mismo problema, estoy tomando cursos de configuracion de routers cisco y quiero saber si me tendre que desenvolver igual con un router delink u otros

14. Ernesto Ariganello - September 16, 2008

Pamela y Gaston, les respondo a la vez: hoy en dia los dispositivos son configurables de diferentes maneras. Existen modos graficos via HTTP que son muy intuitivos y faciles utilizados por todos los fabricantes. Cisco utiliza SDM como interfaz grafica que resulta una herramienta muy poderosa a la hora de configurar (sin ningun tipo de comandos). Sin embargo la base y el entendiminto esta en comprender el funcionamiento de los comandos y por supuesto Cisco es la referencia.

S2

15. pamela - September 19, 2008

gracias por la aclaracion, felicidades por toda la informacion de la pagina que es de gran utilidad.

16. Josefina - October 14, 2008

Hola tengo una pregunta, a ver si me puedes ayudar.

Yo tengo una red con OSPF Y EIGRP las dos redes se conectan con distintos a través un solo router en ese router hice la siguiente configuración:

router eigrp 100
redistribute ospf 100
network 192.168.4.0
network 192.168.5.0
network 192.168.6.0
auto-summary
!
router ospf 100
log-adjacency-changes
redistribute eigrp 100 subnets
redistribute connected
network 192.168.0.0 0.0.255.255 area 0

El problema es que los router que estan basado en EIGRP no pueden comunicarse con los que estan basados en OSPF.
A pesar que en los router OSPF si pueden comunicarse con los EIGRP y se observa en la tabla enrutamiento.
Que puede ser lo que esta pasando? me faltara algo?!

17. Ernesto Ariganello - October 15, 2008

Josefina, debes redistribuir dentro de cada protocolo la metrica correspondiente al otro, no basta con el redistribute [protocolo] hay que hacelo con cada metrica en particular en EIGRP y con el coste en OSPF.

S2

18. Josefina - October 22, 2008

Okp ya lo intente y funciono! Pero me di cuenta que no necesito redistribuir metrica en ospf porque el redistribuye automaticamente, solo coloque el comando subnet. Pero me quedo una duda a ver si me puedes ayudar, en el caso que tenga un router frontera con varias conexiones a routers con ospf y varias conexiones a router con eigrp, como debo colocar las metrica?! Es decir, yo coloque en mi caso el ancho de banda MTU, DELAY y carga del enlace que unia a las dos redes, pero si tengo varios enlaces con distintos ancho de banda y eso, que debo colocar!!

Gracias por tu ayuda.!! Muy buen trabajo.

19. Oriol Mas - March 5, 2009

Buenos días,

¿Es posible redistribuir sólo algunas rutas estáticas? O con el comando redistribute estatic se redistribuyen todas.
Gracias por esta web, es de gran ayuda.

Saludos.

20. jose arias - June 28, 2009

hola, gracias por la toda la informacion que brindas
tengo una consulta, tengo 3 redes con diferentes protocolos RIP, OSPF y EIGRP he configurado la redistribucion de rutas (redistiribute connected), pero el caso es que RIP solo se comunica con OSPF, y EIGRP con OSPF, como puedo hacer para RIP se comunique con EIGRP, es decir, de extremo a extremo? gracias por tu ayuda

21. ernesto - June 29, 2009

Jose, seguramente tengas algo mal en la redistribucion de metricas.

S2

22. Carlos - October 13, 2009

Bueno, he visto varios ejemplos de redistribucion para los 3 protocolos de enrutamiento dinamico, yo suelo hacer todas las practicas en simulador packet tracer 5.1 pero… no me aparece el comando default-metric …. estoy haciendo algo mal?? o es que no existe en el packet tracer??
por que el de redistribute static no hay ningun problema, pero cuando pongo redistribute rip o eigrp u ospf …. como puedo meter la metrica si el comando no existe??

estaria bien que subieras un buen ejemplo en otro link para redistribucion de rutas entre protocolos de enrutamiento dinamico

saludos

23. Angel - March 31, 2010

hola, gracias por la toda la informacion que brindas
tengo una consulta, tengo 4 redes con diferentes protocolos RIP, OSPF cuales son los comandos para ospf a rip

24. Fran - May 26, 2010

necesito configurar una topologia en la cual tengo estoy usando EIGRP y RIP v2, pero no logro conectarlos de manera efectiva, pero no se como hacerlo

25. juanjo - October 8, 2010

me gustaria que con la redistribucion, pueda encontrar en un router central, lo siguiente R*, D*,O*, O*E2, D*EX, como podri hacer esto, que todos estos protocolos me aparezcan en un solo router

26. diego - August 12, 2011

cual es la diferencia entre: redistribute static y default-information originate???

27. francisca - December 22, 2011

redistribute static y default information originate son para dar a conocer a los otros routers que hay una ruta por defecto.

redistribute static ->eigrp
default information originate -> ospf




Hospedado en el Data Center de Tecnocratica