jump to navigation

Proceso de configuración de OSPF en una sola áreaOctober 18, 2006



Habilitar OSPF  por medio del comando:

Router(config)#router ospf process-id
Router(config-router)#network address wildcard-mask area area-id

 

Donde:

process-id es el numero que se usa internamente para identificar si existen múltiples procesos OSPF en ejecución dentro del router.

network identifica las redes directamente conectadas, identificadas por medio de su correspondiente mascara de wildcard

area  para cada red, deberá identificar además a que área pertenece. El área principal o de Backbone es el área 0.

                          

La modificación del ID de router OSPF en una dirección loopback implica definirla de la siguiente manera:

Router(config)#interface loopback number
Router(config-if)#ip address ip-address subnet-mask

La modificación de la prioridad de router implica cambiar la prioridad OSPF de una interfaz por medio del siguiente comando:

Router(config-if)#ip ospf priority number
Router#show ip ospf interface type number

 
Calculo del coste del enlace
El coste se calcula usando la formula 108/bandwidth donde el ancho de banda se expresa en bps. El cisco IOS determina automáticamente el coste basándose en el ancho de banda de la interfaz.

Para modificar el ancho de banda sobre la interfaz utilice el siguiente comando:

Router(config)#interface serial 0/0
Router(config-if)#bandwidth 64
Use el siguiente comando de configuración de interfaz para cambiar el coste del enlace:

Router(config-if)#ip ospf cost number
Comandos de autenticación OSPF

Router(config-if)#ip ospf authentication-key password
Router(config-router)#area area-number authentication
Router(config-if)#ip ospf message-digest-key key-id md5 encryption-type key
Router(config-router)#area area-id authentication message-digest

 

Para configurar los intervalos de Hello y de Dead en una interfaz utilizar los siguientes comandos

Router(config-if)#ip ospf hello-interval seconds
Router(config-if)#ip ospf dead-interval seconds

*En principio el router intentara utilizar un ID buscando interfaces virtuales o loopback,
si no encuentra configuración de las mismas lo hará con la interfaz física con la dirección IP mas alta.
*Los valores de los intervalos de Hello y de Dead deben coincidir en los router adyacentes para que OSPF
funcione correctamente.
*Ante la posibilidad de Flapping los routers esperan unos instantes antes de recalcular su tabla de enrutamiento.

 

 

Algunos comandos para el verificación y control OSPF son:

show ip route
Muestra la tabla de enrutamiento

show ip protocols
Muestra los parámetros del protocolo

show ip ospf neighbors
Muestra la información de los vecinos OSPF

debug ip ospf events
Muestra adyacencias, DR, inundaciones etc.

debug ip ospf packet
Muestra la información de los paquetes

debug ip ospf hello
Muestra las actualizaciones hello

 

 

 

 

 

 
 

Comparte este contenido:
  • Print
  • Digg
  • del.icio.us
  • Facebook
  • Twitter

Si el material de este post te ha sido de utilidad colabora y difúndelo.











Aprenderedes.com fue creado con fines educativos, NO responderé consultas técnicas ni fuera del temario CCNA.»

1. vladimir - October 29, 2006

en la configuracion del comando hello no estoy muy claro en, porque en mi tarea tengo k especifical el tiempo y aqui no me muestra donde debo poner el tiempo.

2. Ernesto Ariganello - October 30, 2006

Los siguientes comandos permiten configurar los tiempos respectivos de hello y dead, donde seconds es el tiempo especificado. Por defecto son de 10 y 40 segundos.

Router(config-if)#ip ospf hello-interval seconds
Router(config-if)#ip ospf dead-interval seconds

Un saludo

3. samir - April 20, 2007

hola mi nombre es samir, soy un superaficioado a las redes y me fustaria saber el proceso basico de configuracion de acls. gracias por tu informcion

4. jegrys - April 26, 2007

hola buenas tardes saludos, quisiera saber como hago para comenzar a realizar un vlsm con una conexion de 4 routers y en donde tengo una area en ospf?

5. letycia - July 18, 2007

HOLA¡¡¡ mm tengo alguanas dudas acerca de ¿que es la mejor opcion al configuarar la proridad o la interface de loopback?
Quisiera saber cual de las dpos es mejor….ventajas y desventajas

6. Ernesto Ariganello - July 19, 2007

Hola, una interfaz de loopback se configura para otorgar un ID de un router en un proceso OSPF, mientras que la prioridad se asigna directamente a la interfaz que participa de un determinado proceso OSPF. En sintesis, loopback ID para todo el router, prioridad para cada una de las interfaces de un router que puede participar de varios procesos OSPF.

Un saludo.

7. Diego (Dc) - July 20, 2007

Hola. Letycia si no configuras una interfaz logica o loopback en un proceso OSPF, la ID de router se tomara de una interfaz física con la IP más alta configurada. Por lo tanto es una práctica recomendable utilizar una interfaz loopback en procesos OSPF ya que si no la tienes configurada y se cae la interfaz física que funciona de ID, tu proceso OSPF caerá también, o no llegara a iniciarse.

Saludos.

8. antonio - July 31, 2007

que hay respecto a el bdr y dr para la configuracio

9. Jose - September 3, 2007

soy un novato en esto pero me gusta lo que es redes quisiera saber donde puedo encontrar un manual q me permita configuracion correcta de ospf de un equipo dlink gracias por la Atencion espero que me contestan a la brevedad
“Quisiera aprender cada dia algo nuevo”

10. LINA - January 31, 2008

me encuentro estudiando administracion de redes de computadores el tema es ospf. que es el DR en ospf

11. Ernesto Ariganello - January 31, 2008

Estimada LINA, en este blog tienes un post dedicado al tema del DR y BDR en ospf.

Un saludo

12. gustavo plaza - March 31, 2008

hola sabes necesito los comandos para vlsm encriptado (contraseña)
saludos

13. Andres d - October 21, 2008

Cordial Saludo

Señor Ernesto primero que todo me gustaria felicitarlo por el Blog tan bueno que a creado. Segundo me gustaria preguntarle de que tan viable podria ser el que le dedique un espacio al tema de configuracion de calidad de servicio ( QoS ).

Gracias

14. Francisco Horacio Ramos Gonzalez - November 9, 2008

Solo un comentario igual que eigrp, el comando network no es para anunciar las redes que tengas directamente conectadas, sino para avisar qie interfaces van a estar anunciando eigrp, de echo puedes poner la ip de tu interfaz y una wilcard de 0.0.0.0 y funcionara igual, o si tienes varias interfaces en las que el primer octeto de la direccion ip es 192 puedes poner 192.0.0.0 0.255.255.255 y pones a las 2 interfaces a anunciar las redes, la direccion de red la toma de la mascara de cada interfaz no con el comando network.
Ademas el comando bandwidth no es para modificar el ancho de banda sino solamente para que ospf haga un calculo adecuado de la metrica, saludos.

15. Ernesto Ariganello - November 11, 2008

Francisco, IS-IS anuncia interfaces IGRP anuncia redes tanto como EIGRP, el juego que puedes hacer con las mascaras comodines o wilcard en el caso de EIGRP solo hace que anuncie lo que tu configures. Es mas, muchas versiones de IOS no admiten el comando network+wilcard ¿entonces?.

Un saludo

16. David - December 31, 2008

Hola Ernesto, quisiera saber como es que se configura una interfaz loopback y si estos son los comandos necesarios que se utilizan para hacerlo….donde puedo encontrar un ejemplo completo de como hacerlo por que lo que es yo todavia no entiendo como configurarla…….o si me podría decir como encontrar ejemplos con graficos…..de antemano muchas gracias saludos Ernesto y mis felicitaciones por el blog muy buen aporte a los que necesitamos saber un poco mas sobre redes…..espero tu respuesta.

17. Ernesto Ariganello - January 1, 2009

David, arriba en el post lo explico

18. lrenjifo - January 4, 2009

Router(config)#interface loopback 0
Router(config-if)#ip address 192.168.31.11 255.255.255.255
Router(config-router)#end

donde mi loopback sera : 192.168.31.11/32

19. ikaros - April 30, 2009

te falto show ip ospf database

20. noxus - May 24, 2009

hola tengo una duda sobre la autenticacion de OSPF, ya vi los comandos y los he estado provando pero no se espeficica si se deben de poner en todos los routers ni tampoco que significa cada linea del comando, por favor que alguien me lo explique porque tengo examen practico mañana y no entiendo esa parte, la neta no se si porque me lo piden si no viene en la curricula de CCNA v4.0 que es lo que estoy estudiando ahorita, ademas ¿alguien me puede decir como configurar un servidor web en una PC?

21. ernesto - May 25, 2009

La autenticacion va en todos los routers que comparten el OSPF ID.
S2

22. Yafte - July 20, 2009

hola me podrian ayudar a saber como crear lista de acceso sobre ospf.

23. GEEK-OVANNI - July 27, 2009

en las redes de multiacceso el tiempo por defecto
es de 40 segundos para hello y el de dead es de 120

en la redes de punto a punto
el tiempo por defecto es de 10 para hello y de 40 para dead

24. Abraham murillo - October 31, 2010

hola tengo una pregunta, como redistribuyo la señal de rip en ospf pasando por una nuve de frame-relay

25. Rafael - March 21, 2011

Hola a todos, mi unica dudo que la palabra FLAPPING. que significa esta palabra o cual es su concepto tenico referente a las redes. gracias

26. ernesto - March 22, 2011

Rafa, flapping se refiere a la fluctuación que una interfaz puede tener, es decir cuando se cae y se levanta de manera continuada. Eso puede provocar indecisiones en los protocolos de enrutamiento si no tienen medidas para ignorar esos “flapeos” o fluctuaciones.

Un saludo

27. andre - October 5, 2012

Gracias por tener este sitio que me a salvado tantas veces. gracias

28. Eusebio - January 18, 2013

como detengo el proceso debug ip ospf events

29. Ernesto - January 20, 2013

Eusebio, anteponiendo un “no” delante del comando:
no debug ip ospf events

O simplemente deteniendo todos los precesos:
no debug all

Saludos




Hospedado en el Data Center de Tecnocratica