jump to navigation

Enrutamiento entre VlansFebruary 2, 2007



Para que las Vlans puedan establecer comunicación entre ellas deben ser necesarios los servicios de un router. Para esto se deben establecer Subinterfaces FastEthernet, encapsulación y dirección IP correspondiente de manera que  cada una de estas pertenezca a un vlan determinada.

Troncal.bmp

Los pasos que siguen establecen las configuraciones de una Subinterfaz FastEthernet
Router(config)#interface fastethernet Nºde slot/Nºde interfaz.Nºde subinterfaz
Router(config-subif)#encapsulation [dot1q|ISL] Nºde vlan
Router(config-subif)#ip address direccion IP+mascara
Router(config-subif)#exit
Router(config)#interface fastethernet Nºde slot/Nºde interfaz
Router(config-if)#no shutdown


Para que la subinterfaz este no shutdown se debe ejecutar este comando directamente desde la interfaz física.
Ejemplo de configuración de un enlace troncal sobre dos subinterfaces:

Router(config)#interface fastethernet 0/0.1
Router(config-subif)#encapsulation dot1q 3
Router(config-subif)#ip address 192.168.1.1 255.255.255.0
Router(config-subif)#exit
Router(config)#interface fastethernet 0/0.2
Router(config-subif)#encapsulation dot1q 3
Router(config-subif)#ip address 200.200.10.1 255.255.255.0
Router(config-subif)#exit
Router(config)#interface fastethernet 0/0
Router(config-if)#no shutdown

Verificación:

show  vlan
 Muestra informacion de las vlans configuradas y los puertos

show  vlan brief
 Muestra la informacion de vlans resumida

show  vtp status
 Muestra la informacion del estado VTP

show  interface trunk
 Muesta los parametros troncales
 
show  spanning-tree vlan Nº
 Muestra el estado de configuracion STP
 

Comparte este contenido:
  • Print
  • Digg
  • del.icio.us
  • Facebook
  • Twitter
  • Publicado en : General
  • Autor : Ernesto

Si el material de este post te ha sido de utilidad colabora y difúndelo.











Aprenderedes.com fue creado con fines educativos, NO responderé consultas técnicas ni fuera del temario CCNA.»

1. aitor - May 30, 2007

Felicidades por el blog.
Me ha parecido muy didactico.

Un saludo

2. Fernando - June 1, 2007

Ernesto,

Genial, esta muy cool tu blog he aprendido y sigo aprendiendo,

Muy buen Material y buen trabajo,

Gracias

3. Giovanny Ortegon - March 22, 2008

La informacion es muy buena y muy practica.

Excelente.

Muchas gracias

4. Arely - May 14, 2008

La informacion es buenisima, solo me gustaria que se explicara mas a fondo los comando show poniendo algunas pantallas con la informacion basica que te tiene que mostrar y que te indica algunas de ellas , esto con el fin de realizar un buen troubleshooting.

Saludos y Gracias por la info.

5. Augusto Pino - May 14, 2008

Ernesto:

Primero felicitarte por el sitio y por le material publicado ya que es muy bueno. Una consulta, para establecer las comunicaciones entre VLANs se puede tambien utilizar al igual que un Router un Firewal Cisco, por ejemplo un ASA o PIX.

Gracias,

Augusto

6. harold - November 20, 2008

Esta muy buena la informacion, ernesto quisiera preguntarte de que manera crearia un enruytamiento entre vlan por medio de un switch capa 3 cisco c3560. gracias.

7. Ernesto Ariganello - November 21, 2008

Harold, los comandos para un multicapa son basicamente los mismos que para un router normal. Creas las Vlans, una interface de salida (como router) que puede ser o no troncal, un protocolo, ACL, etc.

Un saludo

8. Sebastian - December 11, 2008

Ernesto, muy buenas tus explicaciones. Mi consulta es la siguiente:
Tengo 4 routers con Eigrp configurado, de cada router tengo colgado un 2960 con entre 3 y 5 VLANs. El problema que encuentro es que todas las máquinas ven todas las VLANs. En algo con respecto al ruteo estoy metiendo la pata, pero no encuentro que. Me podrás orientar? Lo unico que configuré respecto al ruteo es publicar las distintas redes para que las vea EIGRP. Gracias.

9. Ernesto Ariganello - December 11, 2008

Sebas, es normal ya que eigrp esta anunciando todas las redes conocidas. El paso que debes hacer ahora es filtrar el trafico con ACL para permitir y denegar a quien quieras.

Saludos

10. Hernan - February 18, 2009

Hola buenisimo el sitio. Tengo una duda en este grafico. suponiendo que el router no estuviese. y yo desde un host conectado al switch 1 (izquierda) le tiro un ping a otro host ubicado en el otro switch ambos en la misma vlan. el paquete llega? como actual el switch 1 cuando recibe ese packet?

Espero que me haya exlicado bien. Saludos!

11. xiomara - March 4, 2009

Hola, tengo una duda….Los comandos de configuracion de subinterfaces de un router cisco son los mismos para un switch 3560 capa 3??? si no es asi….como se configura un Switch 3560 capa 3?? como creo la subinterfaces para la comunicacion de las VLAN?????

12. Xiomara - March 18, 2009

Hola Ernesto, tengo la siguiente pregunta:
Como es la configuracion de enrutamiento entre VLANs si en vez de un router utilizo un Switch Catalyst 3560, Capa 3?
Se configuran las subinterfaces igual que un router?? o en que difieren???
Cuales serian los comandos (CLI) de configuracion???

Gracias.
Espero tu pronta respuesta!!!

13. Ricardo - May 27, 2009

Xiomara, los switches capa 3 no soportan subinterfaces como un router, para que haga el enrutamiento entre vlans debes:
1. crear las vlans y asignarles una ip ejem:
Sw1(config)#int vlan 10
Sw1(config)#ip address a.b.c.d. m.m.m.m
Sw1(config#int vlan 20
Sw1(config)#ip address a.b.c.d m.m.m.m
hasta aqui facil no? ahora habilitamos el ruteo en el switch capa 3
Sw1(config)#ip routing y listo ! esto en el switch capa 3.
Las interfaces que conectan los switches debe estar en troncal.
lo demas como dice Ernesto, el puerto hacia el firewall o router deshabilitarlo con Sw1(config)# no switchport y asignarle una ip como si fuera un router.

14. Daniel - November 10, 2009

Me ha servido demasiado.. Gracias!!

15. shatta - November 17, 2009

en un switch capa 3 3560 tengo entendido x lo q he leido aqui q no se pueden hacer sub interfaces, entonces como hago para q sea el capa3 el que me haga el routing entre las vlans y asi evitar q se haga esto en el router??

16. ernesto - November 18, 2009

Shatta, si se pueden configurar sub interfaces en un multicapa.

S2

17. amaya - January 30, 2010

que tal amigos nescesito emular una red wan porlomenos con 4 ruteadores el problema es que no se como configurar los ruteadores para que logren comunicarse entre ello,si alguien sabe como hacerlo se lo agradesco mucho gracias ,,…………

18. ernesto - February 1, 2010

Amaya, tienes toda la informacion que necesitas en este blog……

Un saludo

19. Jose - March 31, 2010

Hola, como puedo hacer para que algunos pocos host de una vlan accedan a recursos de otra vlan. Las vlan estan creadas en un stack formado por switchs 3750.

20. Borja - August 10, 2010

Hola.

Si tengo dos VLAN A y B ya configuradas. Que debo hacer para que los host de VLAN A puedan ver la información de los host en VLANB, pero que los host de VLAN B no puedan ver la información de los host en VLAN A?

Gracias

21. ernesto - August 12, 2010

Borja, debes enrutarlas, y configurar ACL. Busca en el indice tematico ahi tienes toda la informacion.

Un saludo.

22. CTP - October 29, 2010

Hola, excelente información la que brindas amigo. Tengo una duda con respecto al gráfico, el router que muestras lo quiero conectar a otro router que hará de ISP y quisiera que los hosts de la vlan tengan acceso al internet por medio del isp. He configurado una ruta estática en el router que se conecta al switch pero no consigo que los hosts de las vlan tengan acceso a la red de internet.

23. Andrés Salcedo - February 21, 2011

Solo un problema con el código de encapsulation

Router(config)#interface fastethernet 0/0.1
Router(config-subif)#encapsulation dot1q 3 <—
Router(config-subif)#ip address 192.168.1.1 255.255.255.0
Router(config-subif)#exit
Router(config)#interface fastethernet 0/0.2
Router(config-subif)#encapsulation dot1q 3 <—
Router(config-subif)#ip address 200.200.10.1 255.255.255.0
Router(config-subif)#exit

El Vlan ID debe ser el de la vlan correspondiente uno de los dos debe ser encapsulation dot1q 2

o marcaría el siguiente error:

%Configuration of multiple subinterfaces of the same main
interface with the same VID (3) is not permitted.
This VID is already configured on FastEthernet0/0.2.

24. Carlos - June 21, 2011

Hola, muy buena la página.
Quisiera saber si a las vlans que ya se ven por medio de vtp en los switch’s deben tener ip definida, ya que he intentado ponerle ip al servidor de vtp, pero no las transmite.
Al ponerlas a mano, ¿deben ser distintas?, ejemplo:
SW1: vlan2 192.18.70.1
SW2: vlan2 192.18.70.1
¿Necesitan una IP?, Gracias.

25. Antonio - August 24, 2011

Buenas tardes Ernesto.
Estoy confundido con algo y acudo a este blog porque se que explicas muy claro estos temas.
Quisiera aclarar el concepto de Tag vlan, Untag vlan. Como es este proceso ?, si un paquete llega a un pto trocal con un tag vlan que pasa ?…
O si sabes en donde me puedo leer un material bien claro acerca de este tema.

Muchas gracias.

26. ernesto - August 25, 2011

Antonio, el etiquetado de trama se realiza con el fin de que las tramas de cada VLAN se identifiquen para viajar por un troncal. El proceso es el siguiente, una trama entra por un puerto de acceso a un switch, el mecanismo de conmutacion determina que debe ser enviada por un enlace troncal, es en ese momento que se le aplica una etiqueta con su correspondiente número de VLAN. Cuando esta trama llega al puerto troncal del siguiente switch se le quita dicha etiqueta para que finalmente se envie por el puerto de acceso correspondiente. Espero haya sido claro. Puedes ver más info en el indice tematico.

Un saludo

27. César Arturo - September 6, 2011

hola Ernesto ante todo me ha encantado tu pagina, me gusta toda la información que he encontrado aquí ahora esta es mi duda … ya tengo enrutadas mis vlan, una puede hacer ping con la otra pero lo que quiero es por ejemplo que la vlan A se vea con la B y la C no las vea no se si me entientes, en un comentario anterior también querian hacer lo mismo con lo cual le respondiste que configure las ACL, ya he leído sobre las ACL aquí en tu pagina y a parte en internet llevo todo el día en esto y no me sale sigue haciendo ping pareciera que se comunicaran segun tengo entendido al hacer el deny ya no debe de haber comunicacion no?
por ejemplo tengo configurado 2 vlan:
VLAN 10 = 192.168.10.1 (fastEthernet 0/1 – 2)
VLAN 20 = 192.168.20.1 (fastEthernet 0/3 -4)
mi accesslist es = access-list 120 deny ip 192.168.20.0 0.0.0.255 192.168.10.0 0.0.0.255
access-list 120 permit ip any any
interface fastEthernet 0/4
access-grupo 120 in
y esa es la configuración que he puesto según he leido no deberia de haber comunicación y si quisiera que hubiera usaria el icmp no se si esta bien la configuracion que he realizado ante todo muchas gracias por la molestia

28. ernesto - September 6, 2011

Cesar, en principio es correcto, para que dos VLAN enrutadas no se vean deben filtrarse con ACL, en tu caso la lista debe asociarse en la subinterfaz correspondiente en el enlace troncal. SIn duda debe funcionar sin problemas.
access-list 120 deny ip 192.168.20.0 0.0.0.255 192.168.10.0 0.0.0.255
interface fastethernet 0/1.2 (o lo que fuese)
ip access-group 120 in

Suerte

29. César Arturo - September 6, 2011

muchas gracias por contestarme si, supongo que me debe de funcionar sin problemas bueno lo estoy haciendo en el simulador gns3, trabajando como switch un router 3670, en el que rutea las vlans pero como es capa 3 ando probando si soporta lo que son las ACL, seguiré probando y una vez mas muchas gracias

30. ernesto - September 6, 2011

Cesar, si estas trabajando en multicapa debes asociar la ACL a la “interfaz VLAN XNº” no a la interfaz fisica, pero entonces nos vamos del temario del CCNA.

A experimentar que es como se aprende!

31. César Arturo - September 6, 2011

Ernesto, muchas gracias por la respuesta que me diste creo que me habia confundido pero ya entendí muy bien con lo que me dijiste de interfaz VLAN XN, asigné el access grop a la interfaz VLAN 20 y ahora ya no puede hacer ping, me había confundido, leí en internet y observé videos en youtube y me aclaró el panorama jeje, muchas gracias por la paciencia y me ha encantado tu página y me ha servido de gran ayuda en mi tesis de carrera

32. Gabriel - June 28, 2012

Hola tengo una duda….
existe el enrutamiento en layer 2?
que es?
cual es el objetivo?
y que fabricantes lo promueven?

si me pudieran responder les agradecería un montón.
Gracias.




Hospedado en el Data Center de Tecnocratica